-->

sexta-feira, 19 de outubro de 2007

Acesso negado no MSconfig

Nunca havia acontecido antes, mas só esta semana já me deparei duas vezes com esta mensagem, ao tentar fazer qualquer alteração no Windows com o msconfig.exe :

"erro de acesso negado ao tentar alterar um serviço. Talvez você tenha de fazer logon usando uma conta de administrador para fazer as alterações especificadas."

Óbviamente eu estava usando uma conta de administrador nas duas ocorrências. Isso ocorreu com dois clientes completamente distintos, que me chamaram por motivos diferentes. A mensagem não impede que as alterações sejam feitas.

Pesquisando no Google, encontrei uma possível explicação.

Aparentemente, a HP encontrou uma vulnerabilidade em um de seus gigantescos "drivers" de impressão e fez um patch que foi instalado automáticamente nas máquinas dos usuários de algumas de suas impressoras. Esse driver ou algum serviço instalado por ele parece estra tomado por excesso de paranóia, daí o problema.

Existem relatos de que o problema pode ser provocado por alguns programas de firewall, mas nenhum dos dois clientes tinha firewall instalado. E ambos possuem impressoras HP.


[24/12/07] O problema apareceu no notebook da minha irmã. E ela também usa uma impressora HP. Eu ainda não tenho solução para isso.
[07/04/08] O problema apareceu no meu PC principal. Eu também uso uma impressora HP, mas é uma Laserjet 1100, que não carrega nenhum processo automático que poderia fazer uma atualização sem meu consentimento. Pelo menos não que eu saiba...

49 comentários:

  1. Eu tive esse problema, resolvi usando outro comando, que agora eu não me lembro, só sei que a extensão do comando é .msc, quando me lembrar eu posto aqui, eu também tenho impressora HP, mas no meu caso acho que foi virus pois perdi acesso ao regedit e outras coisas sumira do xp

    ResponderExcluir
  2. cara bem provavel que seja um virus...eu vivia com o xp e o antivirus sempre atualizado e mesmo assim acabava pegando pragas....muitas vez por culpa de brejas do windows..entao o que fiz instalei o linux....agora nao volto pra essa peneira do windows nunca mais...

    ResponderExcluir
  3. Pode ter sido "services.msc", mas existem vários outros (são 17 em c:\windows\system32). Usar services.msc vai ajudar a resolver meu problema quando eu souber qual o serviço está provocando o sintoma, se for um serviço.

    O seu caso é outro. O de meus clientes não foi infecção.

    ResponderExcluir
  4. jah tive um problema parecido com esse ae, usei o TuneUP Utilities e resolveu o meu problema, tb tive um problema parecido com esse que bloqueou meu gerenciador de tarefas, mas nesse caso tive que criar uma nova conta admin, e migrar os arquivso pessoais, tb resolveu.

    ResponderExcluir
  5. rfariasbsb,

    Muitos problemas no Windows, assim como no Linux, são provocados por erros nos programas instalados, não sendo em nenhum dos dois casos culpa do Sistema Operacional.

    Eu trabalho em minha máquinas 100% do tempo como Administrador e a atualização do XP em todas elas é propositalmente desligada por mim (meu XP atualiza, mas eu não quero que faça isso) e mesmo assim não pego vírus. Aliás, uma delas nem anti-virus instalado tem, apesar de estar 100% do tempo conectada à internet. Como eu disse em um post há semanas, basta ter bom senso para se manter seguro contra a maioria dos malwares.

    Usar Linux não é opção viável nem para mim, nem para meus clientes. A não ser que seja como servidor ou em aplicações específicas.

    ResponderExcluir
  6. Leonardo Lage26/10/07 12:47

    Estou com este problema no meu pc!
    E não sei como resolver ainda!
    Tambem tenho uma HP instalada aqui. Será que é ela? Mas instalei apenas o driver.

    ResponderExcluir
  7. Caro Jefferson Ryan,

    Primeiramente gostaria de lhe parabenizar pelo ótimo conteúdo do seu blog. Estou lendo ele já tem uns 40 minutos e até agora só achei informação interessante aqui.
    Não comentei nos outros posts pois estava justamente procurando um post onde eu poderia ser útil e, talvez tenha achado agora.
    Não sei se no caso dos seus clientes foi problema com drives da HP, mas eu já tive esse problema em alguns clientes e resolvi da seguinte forma:

    Iniciar, Executar, gpedit.msc, OK

    Dentro de Diretivas de Grupo (a janelinha que abriu), vá até Configuração do Usuário, Modelos Administrativos, Sistema. Dentro de Sistema, procure a chave "Impedir acesso a ferramentas de edição do Registro". Clique duas vezes nessa chave e modifique para "Desativado".

    Não me lembro agora se é necessário reiniciar o computador ou apenas fazer um logoff (pela lógica um logoff resolveria).

    Espero que o seu problema seja resolvido. Por favor, me envie um e-mail caso o problema persista para que eu possa verificar o que posso fazer.

    Obrigado pelo ótimo blog.

    ResponderExcluir
  8. Guilherme,

    Obrigado pela colaboração, mas penso que você entendeu errado o problema.

    Pelo que sei, essa diretiva de segurança impede o usuário de usar o Msconfig. Conforme eu expliquei, o uso do Msconfig é normal, exceto pela mensagem.

    ResponderExcluir
  9. Sim, Jefferson... essa diretiva de segurança pode tanto permitir quanto negar acesso ao MSConfig :)

    Por isso, na chave de configuração da mesma, você deve marcar como "Desativado" para que ela anule qualquer outra configuração e/ou diretiva de segurança que esteja negando acesso ao MSConfig ou qualquer outra ferramenta para alteração do registro do Windows.

    Note, você estará DESATIVANDO a opção de "Impedir acesso a ferramentas de edição do Registro".

    ResponderExcluir
  10. Guilherme,

    Eu ainda não estou entendendo qual a relação dessa diretiva de segurança com o problema que descrevo neste post.

    Repetindo: o uso do msconfig é normal, exceto pela mensagem. Se essa diretiva estivesse em uso eu não poderia usar o msconfig.

    E gpedit.msc nem existe no Windows XP Home. Dois dos computadores onde encontrei esse problema usam essa versão. Os outros, não sei.

    ResponderExcluir
  11. COm certeza tem a ver com o drive da HP, pois comigo foi depois de instalar o drive da HP, e na loja do meu amigo isso acontecia e ele tinha uma impressora HP..

    tem tudo a ver...

    vamos procurar a solucao..

    flW!

    ResponderExcluir
  12. Alguém conseguiu uma solução? estou tendo o mesmo problema...

    ResponderExcluir
  13. Guilherme..

    Parabens pelo Blog...

    Estava lá eu procurando uma soluçao para esse problema quando acabei chegando aqui !

    Sem Mais Nem Longas... Queria Postar aqui a soluçao !!

    Apos Muitas e muitas pesquisas encontrei um forum em Ingles que resolvel meu problema !!

    E Espero que resolva o de vcs tbm !!

    Lá vai...

    Recomendo antes de qualquer alteraçao no PC... Faça um ponto de Restauraçao !

    1. Vá em Iniciar> Executar
    2. Digite REGEDIT e de Enter ou Clique em OK.
    3.Clique sobre os sinais (+) ao lado esquerdo das pastas nos itens citados abaixo.
    # HKEY_LOCAL_MACHINE
    # System
    # CurrentControlSet
    # Services
    # PML Driver HPZ12
    4.Na tela do lado direito Procurar por START e de duplo clique sobre ela.
    5.Mude o Valor Decimal para um dos citados abaixo !
    2 > Automatico
    3 > Manual
    4 > Desativado
    [Testei Desativado e Manual Funcionou com os dois !]
    6.Clique em OK.
    7.Feche o Editor de Registro.
    8.Reinicie o Computador !

    Boa Sorte e Boa Tarde !

    FOnte: http://www.pchell.com/support/msconfig_access_denied_error.shtml

    ResponderExcluir
  14. Consegui resolver meu problema em X:\Arquivos de programas\HP\Digital Imaging\bin\hpqdirec.exe ou seja Central de Soluções HP>Atualização de Software HP!

    ResponderExcluir
  15. É pessoal, fiquei muito empolgado com todas as sugestões do blog, mas infelizmente nenhuma delas resolveu meu caso. Já rodei vários anti-vírus, inclusive específicos para o Bagle que é citado em muitos fóruns como o causador desse bloqueio parcial ao MSConfig. Gostaria muito se alguém encontrou solução diferente postar aqui por favor! Agradeço a todos e parabéns pelo Blog!
    Gildicley Alves

    ResponderExcluir
  16. Pois é. Eu também testei todas as soluções apresentadas aqui e nada mudou.

    ResponderExcluir
  17. Eu desabilitei o serviço PML Driver HPZ12 no Regedit e agora estou alterando o msconfig normalmente.
    Solução testada e aprovada!

    ResponderExcluir
  18. Oi,gente.Eu to c/ esse problema aki no meu msconfig,no entanto,eu nao tenho impressora Hp nao.Não tenho ideia do q fazer!!Se alguem puder ajudar,agradeço.

    ResponderExcluir
  19. Pois é... comigo tbm ta acontecendo.. mas eu nao tenho HP...

    Será que todo esse povo que comentou aqui ainda tá com esse problema, ou resolveu e nem compartilhou?? =(

    ResponderExcluir
  20. tb tenho o mesmo problema e nao tenho nada da HP (amém)

    ResponderExcluir
  21. vipper1006/6/08 23:48

    Só uma pergunta, por acaso algum de vcs tem instalado o spybot? pode ser ele.

    ResponderExcluir
  22. É um m* mesmo... eu já tinha visto esta msg em muitos lugares e também no meu computador. Recentemente formatei e de início nada da msg, nao tenho nada da HP nem Spybot... de uma hora para outro simplesmente a msg voltou a aparecer... coisas da vida!

    ResponderExcluir
  23. Não sei já conseguiram revolver o problema de vcs, mas como aconteceu o mesmo comigo e eu consegui revolve-lo decidi postar aki, no meu caso o que gerou a msg foi a instalação do modulo de segurança do meu banco, uma vez que eu ñ tenho nem HP e nem o Spybot, ele instala um plugin GBPlugin, ele nega acesso a algumas chaves de registros. A solução eu encontrei forum clube do Hardware http://forum.clubedohardware.com.br/remover-gbplugin/518260 "remove_GbPlugin", espero ter ajudado

    ResponderExcluir
  24. NADA ACIMA RESOLVEU MEU PROBLEMA, TENHO HP, SPYBOT E NADA

    ResponderExcluir
  25. ocorreu o erro após instalar uma impressora HP.

    só foi resolvido com a sugestao da Layla: remove_GbPlugin (http://www.4shared.com/file/55436461/942cfb60/remove_GBPlugin.html)

    ResponderExcluir
  26. Bom Dia!

    probleminha interessante!

    eu segui as cordenadas do "Drop" e alterei no registro lá para "Desativado" e nao apareceu mais a mensagem ao alterar alguma coisa no MSConfig...

    porém a dúvida, não vai alterar nada em relação a minha impressora hp? driver? erro de comunicação? nada?

    Obrigado pela ajuda!

    Blog da hora!

    ResponderExcluir
  27. Anônimo9/1/09 04:55

    tenho esse problema em 5 máquinas 3 delas nem impressora tem, nem uso banco......continuo aguardando solução definitiva...
    nada disso ai em cima serviu pro meu caso, que é idêntico, altero o msconfig, mas tenho que confirmar a tal mensagem chata!

    ResponderExcluir
  28. Resolvendo facilmente o problema!

    Fiz um backup !

    Formatei!

    Instalei SP3 ORIGINAL !!!

    Sem mais.

    ResponderExcluir
  29. Anônimo,

    Formatar funciona até você instalar de novo o software que causa o problema.

    Esse problema também ocorre no XP SP3.

    ResponderExcluir
  30. Eu tambem estou com o mesmo problema e possuo uma multfuncional HP DeskJat F4180.
    Vou testar a dica do Gullherme e si resolver eu posto aqui

    ResponderExcluir
  31. Olha eu formatei meu pc ontem e fui instalando drives por drive e fazendo testes para descobrir si realmente esse problema si partia da HP.
    Fui instalando os drives mas quando eu instalei o navegador FireFox versao 3.0.8 ai aconteceu o problema. Ai tentei restaurar o SO e de nada resolveu.
    Ou seja o problema todo esta acontecendo por causa do navegador FireFox!
    Mas ainda nao descobrir como resolver o problema.
    Ate o momento o unico jeito que encontrei é formatando o pc e reinstalando tudo novamente e esquecendo do FireFox pois se instalar ele o problema voltará.

    ResponderExcluir
  32. Algum de você nao usa o SP3 e tem esse problema ?

    ResponderExcluir
  33. Instalei o Firefox 3.0.9 e o problema também existe...
    Coisa chata eihn?
    Estou com esse problema no PC e no Note!
    O pior é que quando inicializam às vezes não inicializam alguns programas (antí-vírus, bluetooth, controlador de volume, o RealTek) e não consigo dar jeito...

    ResponderExcluir
  34. Esse problema começou esses dias comigo...
    Primeiro nos PCs do trabalho e agora acabou de acontecer em casa...

    Detalhe: NÃO USO HP EM CASA ! ! ! USO UMA EPSON STYLYS CX4900 ! ! !

    E aí?

    ResponderExcluir
  35. F**U tenho uma HP, firefox...

    ResponderExcluir
  36. Estava com este problema. Estou usando o SP3 e tenho impressora HP. Foi só desativar usando a dica do Deny que logo depois o msconfig voltou ao padrão com tudo ativado. Valeu, obrigado.

    ResponderExcluir
  37. Este comentário foi removido por um administrador do blog.

    ResponderExcluir
  38. Não sei o que causa, mas se quiser retirar algum servico do iniciar automático com ou sem permissão baixe o easy cleaner e use a opção Iniciar dele, é rápido e sem as frescuras do windows

    ResponderExcluir
  39. Frank,

    Isso não tem nada a ver com o problema deste post.

    ResponderExcluir
  40. jeffersonjbj, qual é a dica do Deny???

    Estou com o mesmo problema.
    Só como referência, ainda não testei nenhuma das dicas.

    Tenho impressora HP, não uso Firefox, SO:Windows XP Home original com SP3.
    Sergio

    ResponderExcluir
  41. Tenho o mesmo problema com MSCONFIG, e por causa desse aviso de logon o MSSQL Express não funciona corretamente. quando tenho que compilar meu programa ou acessar o DataModule dele não acessa devido uma restrição do MSSQL. E mais o regedit também não abre. Não tenho HP mas uso o firefox.
    Ajuda aí!

    ResponderExcluir
  42. tou com o mesmo problema mas olhando nos pots acima vi um comentario que aconteceu igual ao meu pc...
    Ao instalar o novo firefox 3.5.5 o tal problema
    "erro de acesso bla bla" começou...
    tenho HP e nunca tinha dado esse erro antes..
    apareceu depois que atualizei o firefox ...
    Pode ser algum problema em conjunto HP e firefox ?
    Vou deletar meu firefox e ver que consigo...
    se der certo volto aqui novamente e digo os passos que tomei...
    abraço e boa sorte a nós todos...

    ResponderExcluir
  43. Bom dia a todos!
    Lendo os posts, vi que estão com o mesmo problema que eu e como dito acima provavelmente é causado pelo GBplugin programa usado pelos netbankings no meu caso BB, desative ele que funciona normal.

    ResponderExcluir
  44. TODO MUNDO AQUI JÁ ACESSOU ALGUMA CONTA DO BANCO DO BRASIL OU REAL NA MÁQUINA COM ESSE PROBLEMA?
    Já formatei 3 vezes, o problema sempre vem depois q acesso o site do banco.
    O BB fez umas mudanças em suas seguranças e acabou criando essa kgada no plugin de segurança. Então, tentem desinstalar ele.

    ResponderExcluir
  45. Anônimo2/4/10 11:33

    Nada tem resolvido

    ResponderExcluir
  46. Já removi o GBplugin e o PML Driver HPZ12 já estava desativado. Esse mesmo problema ainda persiste e não consigo instalar o software da minha impressora HP. :/

    ResponderExcluir
  47. Olá, tbm estive com o mesmo problema, e sim o computador do cliente tem uma HP, não sei se o caso é o mesmo com vocês, mas pelo menos comigo mesmo aparecendo a m* mensagem ele desmarca a opção. Depois que reiniciei o computador realmente a opção estava desmarcada, sendo assim não fazendo diferença a msg.
    Não tenho como desinstalar o driver da impressora para ter certeza se é dela, mas caso alguem vai fazer de tudo para resolver isso, desinstale todos os drivers e utilitários da impressora e vê se o problema persiste, isso vale também para o firefox. Assim que formatar o computador tente acessar o msconfig se ele estiver funcionando vá criando pontos de instalação, intalando seus softwares normalmente e testando o msconfig, para assim verificar quem é o causador, se o problema der assim que você instalar o windows com certeza é algum driver do seu computador.

    abrçs
    @_C3low

    ResponderExcluir
  48. secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose
    coloca isso no promp de comando

    ResponderExcluir

Siga as regras do blog ou seu comentário será ignorado.